# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b[AEIOUaeiou]\S*/XXXXX/g;t' <<< "Hello 12 I am John How are you I am good ou%e Thank you 89767 0 #$%^"