// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\b[AEIOUaeiou]\S*").unwrap();
let string = "Hello 12 I am John How are you I am good ou%e Thank you 89767 0 #$%^";
let substitution = "XXXXX";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}