$re = '/\b[AEIOUaeiou]\S*/';
$str = 'Hello 12 I am John How are you I am good ou%e Thank you 89767 0 #$%^';
$subst = "XXXXX";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;