re = /\b[AEIOUaeiou]\S*/
str = 'Hello 12 I am John How are you I am good ou%e Thank you 89767 0 #$%^'
subst = 'XXXXX'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result