import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^.*\\n|.*$)";
final String string = "[abilities]\n"
+ "UnknownDescTech0 = このアビリティの効果は不明。\n"
+ "UnknownDescFun0 = 説明なし。\n"
+ "UnknownName = ???のアビリティ。\n\n"
+ "OneHitDeathName = ワンパンヒーローのバッジ\n"
+ "OneHitDeathDesc0 = 一発で死にます。上級者向け!\n\n"
+ "SuckInOrbsName = 磁石のバッジ\n"
+ "SuckInOrbsFun0 = アイテムに手が届かない? これでもう安心。\n"
+ "SuckInOrbsTech0 = 自動で近くのアイテムを引き寄せます!\n\n\n"
+ "[abilities_test]\n"
+ "UnknownName = ??? Ability\n"
+ "UnknownDescFun0 = No description.\n"
+ "UnknownDescTech0 = This ability does not seem to have any purpose.\n\n"
+ "OneHitDeathName = 1-Hit Hero Badge\n"
+ "OneHitDeathDesc0 = You die in one hit. Only for the brave!\n\n"
+ "SuckInOrbsName = Item Magnet Badge\n"
+ "SuckInOrbsFun0 = Item just out of reach? No longer a problem!\n"
+ "SuckInOrbsTech0 = Automatically attract nearby collectibles!";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}