$re = '/(^.*\n|.*$)/m';
$str = '[abilities]
UnknownDescTech0 = このアビリティの効果は不明。
UnknownDescFun0 = 説明なし。
UnknownName = ???のアビリティ。
OneHitDeathName = ワンパンヒーローのバッジ
OneHitDeathDesc0 = 一発で死にます。上級者向け!
SuckInOrbsName = 磁石のバッジ
SuckInOrbsFun0 = アイテムに手が届かない? これでもう安心。
SuckInOrbsTech0 = 自動で近くのアイテムを引き寄せます!
[abilities_test]
UnknownName = ??? Ability
UnknownDescFun0 = No description.
UnknownDescTech0 = This ability does not seem to have any purpose.
OneHitDeathName = 1-Hit Hero Badge
OneHitDeathDesc0 = You die in one hit. Only for the brave!
SuckInOrbsName = Item Magnet Badge
SuckInOrbsFun0 = Item just out of reach? No longer a problem!
SuckInOrbsTech0 = Automatically attract nearby collectibles!';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);