import re
regex = re.compile(r"(^.*\n|.*$)", flags=re.MULTILINE)
test_str = ("[abilities]\n"
"UnknownDescTech0 = このアビリティの効果は不明。\n"
"UnknownDescFun0 = 説明なし。\n"
"UnknownName = ???のアビリティ。\n\n"
"OneHitDeathName = ワンパンヒーローのバッジ\n"
"OneHitDeathDesc0 = 一発で死にます。上級者向け!\n\n"
"SuckInOrbsName = 磁石のバッジ\n"
"SuckInOrbsFun0 = アイテムに手が届かない? これでもう安心。\n"
"SuckInOrbsTech0 = 自動で近くのアイテムを引き寄せます!\n\n\n"
"[abilities_test]\n"
"UnknownName = ??? Ability\n"
"UnknownDescFun0 = No description.\n"
"UnknownDescTech0 = This ability does not seem to have any purpose.\n\n"
"OneHitDeathName = 1-Hit Hero Badge\n"
"OneHitDeathDesc0 = You die in one hit. Only for the brave!\n\n"
"SuckInOrbsName = Item Magnet Badge\n"
"SuckInOrbsFun0 = Item just out of reach? No longer a problem!\n"
"SuckInOrbsTech0 = Automatically attract nearby collectibles!")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")