#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\[QUOTE=[\s\S]+\[\/QUOTE\]"
Local $sString = "[QUOTE=UserAdmin;22061013]" & @CRLF & _
" [SIZE="4"]" & @CRLF & _
" [LEFT]" & @CRLF & _
" [COLOR="DarkGreen"] Sample text goes here [/COLOR]" & @CRLF & _
" [/LEFT]" & @CRLF & _
" [/SIZE]" & @CRLF & _
"[/QUOTE]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")