import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[QUOTE=[\\s\\S]+\\[\\/QUOTE\\]";
final String string = "[QUOTE=UserAdmin;22061013]\n"
+ " [SIZE=\"4\"]\n"
+ " [LEFT]\n"
+ " [COLOR=\"DarkGreen\"] Sample text goes here [/COLOR]\n"
+ " [/LEFT]\n"
+ " [/SIZE]\n"
+ "[/QUOTE]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}