package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\[QUOTE=[\s\S]+\[\/QUOTE\]`)
var str = `[QUOTE=UserAdmin;22061013]
[SIZE="4"]
[LEFT]
[COLOR="DarkGreen"] Sample text goes here [/COLOR]
[/LEFT]
[/SIZE]
[/QUOTE]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}