re = /\[QUOTE=[\s\S]+\[\/QUOTE\]/m
str = '[QUOTE=UserAdmin;22061013]
[SIZE="4"]
[LEFT]
[COLOR="DarkGreen"] Sample text goes here [/COLOR]
[/LEFT]
[/SIZE]
[/QUOTE]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end