package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(1\s?)?((\([0-9]{3}\))|[0-9]{3})[\s\-]?[\0-9]{3}[\s\-]?[0-9]{4}$`)
var str = `872-456-4532
(872) 456-4532
8724564532
1 872-456-4532
1 (872) 456-4532`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}