$re = '/^(1\s?)?((\([0-9]{3}\))|[0-9]{3})[\s\-]?[\0-9]{3}[\s\-]?[0-9]{4}$/m';
$str = '872-456-4532
(872) 456-4532
8724564532
1 872-456-4532
1 (872) 456-4532';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;