use strict;
my $str = '872-456-4532
(872) 456-4532
8724564532
1 872-456-4532
1 (872) 456-4532';
my $regex = qr/^(1\s?)?((\([0-9]{3}\))|[0-9]{3})[\s\-]?[\0-9]{3}[\s\-]?[0-9]{4}$/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";