using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[8|:|;|\*]{1}[-c^;\*]?\)";
string input = @"(my name is zeeze :) and I am very happy ;))";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}