re = /[8|:|;|\*]{1}[-c^;\*]?\)/
str = '(my name is zeeze :) and I am very happy ;))'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end