package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[8|:|;|\*]{1}[-c^;\*]?\)`)
var str = `(my name is zeeze :) and I am very happy ;))`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}