$re = '/[8|:|;|\*]{1}[-c^;\*]?\)/';
$str = '(my name is zeeze :) and I am very happy ;))';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);