const regex = /(?<FULL>^(?<PATH>(?:\/|\.|\.\.){0,2})(?<CAPTURE1>\/[^\/\s]+)?(?<CAPTURE2>\/[^\/\s]+)?(?<CAPTURE3>\/[^\/\s]+)?(?<CAPTURE4>\/[^\/\s]+)?(?<CAPTURE5>\/[^\/\s]+)?(?<CAPTURE6>\/[^\/\s]+)?(?<FILENAME>\/[^\/\s]+)$)/igm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<FULL>^(?<PATH>(?:\\\/|\\.|\\.\\.){0,2})(?<CAPTURE1>\\\/[^\\\/\\s]+)?(?<CAPTURE2>\\\/[^\\\/\\s]+)?(?<CAPTURE3>\\\/[^\\\/\\s]+)?(?<CAPTURE4>\\\/[^\\\/\\s]+)?(?<CAPTURE5>\\\/[^\\\/\\s]+)?(?<CAPTURE6>\\\/[^\\\/\\s]+)?(?<FILENAME>\\\/[^\\\/\\s]+)$)', 'igm')
const str = `./src/index.js
./src/index.js#Soda
./src/index.js?soda=fries
./src/index.js#soda?fries=hamburger
./src/index.js#soda?fries=hamburger&bag+o=chips
http://www.google.com/blugh/hello
https://www.google.com:8080/src/ui/template-management/create-template/versioning/version.js
http://localhost:8080/blugh/hello
../MyPath
This here is a normal sentence, though!
./src/ui/{FILE}.js[x]?
./src/ui/login.js
./src/ui/logout.js
./src/ui/{FILE}/{FILE}.js[x]?
./src/ui/ad-hoc-messages/ad-hoc-messages.js
./src/ui/editor/editor.jsx
./src/ui/select-interaction/select-interaction.jsx
./src/ui/template-management/template-management.js
./src/ui/{DIR}/{FILE}/{FILE}.js[x]?
./src/ui/ad-hoc-messages/send-ad-hoc-message/send-ad-hoc-message.js
./src/ui/admin-console/Department-management/Department-management.js
./src/ui/admin-console/tag-management/tag-management.js
./src/ui/template-management/create-template/create-template.js
./src/ui/template-management/create-template/versioning/version.js
./src/ui/{DIR}/{FILE}.js[x]?
./src/ui/shared/select-template-to-send.js
/select-interaction
/template-management
/template-management/create-template
/template-management/edit-template
/ad-hoc-messages
/ad-hoc-messages/send-ad-hoc-mail
/admin-console/category-management
/admin-console/tag-management
/Logout`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}