// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?im)(?<FULL>^(?<PATH>(?:\/|\.|\.\.){0,2})(?<CAPTURE1>\/[^\/\s]+)?(?<CAPTURE2>\/[^\/\s]+)?(?<CAPTURE3>\/[^\/\s]+)?(?<CAPTURE4>\/[^\/\s]+)?(?<CAPTURE5>\/[^\/\s]+)?(?<CAPTURE6>\/[^\/\s]+)?(?<FILENAME>\/[^\/\s]+)$)").unwrap();
let string = "./src/index.js
./src/index.js#Soda
./src/index.js?soda=fries
./src/index.js#soda?fries=hamburger
./src/index.js#soda?fries=hamburger&bag+o=chips
http://www.google.com/blugh/hello
https://www.google.com:8080/src/ui/template-management/create-template/versioning/version.js
http://localhost:8080/blugh/hello
../MyPath
This here is a normal sentence, though!
./src/ui/{FILE}.js[x]?
./src/ui/login.js
./src/ui/logout.js
./src/ui/{FILE}/{FILE}.js[x]?
./src/ui/ad-hoc-messages/ad-hoc-messages.js
./src/ui/editor/editor.jsx
./src/ui/select-interaction/select-interaction.jsx
./src/ui/template-management/template-management.js
./src/ui/{DIR}/{FILE}/{FILE}.js[x]?
./src/ui/ad-hoc-messages/send-ad-hoc-message/send-ad-hoc-message.js
./src/ui/admin-console/Department-management/Department-management.js
./src/ui/admin-console/tag-management/tag-management.js
./src/ui/template-management/create-template/create-template.js
./src/ui/template-management/create-template/versioning/version.js
./src/ui/{DIR}/{FILE}.js[x]?
./src/ui/shared/select-template-to-send.js
/select-interaction
/template-management
/template-management/create-template
/template-management/edit-template
/ad-hoc-messages
/ad-hoc-messages/send-ad-hoc-mail
/admin-console/category-management
/admin-console/tag-management
/Logout";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}