using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[A-Z]([a-z][A-Z])*[a-z]?";
string input = @"aBcDef
cDefgh
aBefgh
aBcDgh
aBcDef
BcDefgh
acDefgh
aBDefgh
aBcefgh
aBcDfgh
aBcDegh
aBcDefh
aBcDefg";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}