package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[A-Z]([a-z][A-Z])*[a-z]?`)
var str = `aBcDef
cDefgh
aBefgh
aBcDgh
aBcDef
BcDefgh
acDefgh
aBDefgh
aBcefgh
aBcDfgh
aBcDegh
aBcDefh
aBcDefg`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}