$re = '/[A-Z]([a-z][A-Z])*[a-z]?/m';
$str = 'aBcDef
cDefgh
aBefgh
aBcDgh
aBcDef
BcDefgh
acDefgh
aBDefgh
aBcefgh
aBcDfgh
aBcDegh
aBcDefh
aBcDefg';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);