re = /[A-Z]([a-z][A-Z])*[a-z]?/m
str = 'aBcDef
cDefgh
aBefgh
aBcDgh
aBcDef
BcDefgh
acDefgh
aBDefgh
aBcefgh
aBcDfgh
aBcDegh
aBcDefh
aBcDefg'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end