use strict;
my $str = '------ Regla -------
12345678901234567890
----------------*---
11111111111111000
1111111111
10101010
11111111111111111
111111111111111111111
1010101010101010101010
10101010101010100
Otros números no en base 2:
123456789011121314151617181920
1234
';
my $regex = qr/1[10]{16,}/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}