# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"1[10]{16,}"
test_str = ("------ Regla -------\n"
"12345678901234567890\n"
"----------------*---\n"
"11111111111111000\n"
"1111111111\n"
"10101010\n"
"11111111111111111\n"
"111111111111111111111\n"
"1010101010101010101010\n"
"10101010101010100\n\n"
"Otros números no en base 2:\n"
"123456789011121314151617181920\n"
"1234\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.