// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)1[10]{16,}").unwrap();
let string = "------ Regla -------
12345678901234567890
----------------*---
11111111111111000
1111111111
10101010
11111111111111111
111111111111111111111
1010101010101010101010
10101010101010100
Otros números no en base 2:
123456789011121314151617181920
1234
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}