re = /1[10]{16,}/m
str = '------ Regla -------
12345678901234567890
----------------*---
11111111111111000
1111111111
10101010
11111111111111111
111111111111111111111
1010101010101010101010
10101010101010100
Otros números no en base 2:
123456789011121314151617181920
1234
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end