package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:\d{1,3}(?:,\d{3})*|\d+)(?:\.\d{1,2})?`)
var str = `2,836,433.182,201,355.6422.39`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}