re = /(?:\d{1,3}(?:,\d{3})*|\d+)(?:\.\d{1,2})?/m
str = '2,836,433.182,201,355.6422.39'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end