const regex = new RegExp('(?:\\d{1,3}(?:,\\d{3})*|\\d+)(?:\\.\\d{1,2})?', 'gm')
const str = `2,836,433.182,201,355.6422.39`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}