$re = '/(?:\d{1,3}(?:,\d{3})*|\d+)(?:\.\d{1,2})?/m';
$str = '2,836,433.182,201,355.6422.39';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);