#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(([A-z][0-9]+)|([0-9]+))$"
Local $sString = "N00044" & @CRLF & _
"n0" & @CRLF & _
"n09" & @CRLF & _
"n099" & @CRLF & _
"AS2" & @CRLF & _
"Nf2" & @CRLF & _
"nf_2" & @CRLF & _
"nf 08" & @CRLF & _
"n09 0" & @CRLF & _
"N 0009" & @CRLF & _
"N000a" & @CRLF & _
"123456" & @CRLF & _
"023465356" & @CRLF & _
"as2" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")