import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(([A-z][0-9]+)|([0-9]+))$";
final String string = "N00044\n"
+ "n0\n"
+ "n09\n"
+ "n099\n"
+ "AS2\n"
+ "Nf2\n"
+ "nf_2\n"
+ "nf 08\n"
+ "n09 0\n"
+ "N 0009\n"
+ "N000a\n"
+ "123456\n"
+ "023465356\n"
+ "as2\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}