re = /^(([A-z][0-9]+)|([0-9]+))$/m
str = 'N00044
n0
n09
n099
AS2
Nf2
nf_2
nf 08
n09 0
N 0009
N000a
123456
023465356
as2
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end