package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(([A-z][0-9]+)|([0-9]+))$`)
var str = `N00044
n0
n09
n099
AS2
Nf2
nf_2
nf 08
n09 0
N 0009
N000a
123456
023465356
as2
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}