const regex = /[^\n\d{6,}](?:(?:[a-z\s.]+(\n[a-z\s.])*)|.+)/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^\\n\\d{6,}](?:(?:[a-z\\s.]+(\\n[a-z\\s.])*)|.+)', 'gmi')
const str = `xxx
27223525
West Food Group B.V.
52608670
Westcon
Group European Operations Netherlands Branch
30221053
Westland Infra Netbeheer B.V.
27176688
Wetransfer B.V.
34380998
WETRAVEL B.V.
70669783`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}