re = /[^\n\d{6,}](?:(?:[a-z\s.]+(\n[a-z\s.])*)|.+)/mi
str = 'xxx
27223525
West Food Group B.V.
52608670
Westcon
Group European Operations Netherlands Branch
30221053
Westland Infra Netbeheer B.V.
27176688
Wetransfer B.V.
34380998
WETRAVEL B.V.
70669783'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end