import re
regex = re.compile(r"[^\n\d{6,}](?:(?:[a-z\s.]+(\n[a-z\s.])*)|.+)", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("xxx\n\n"
"27223525\n\n"
"West Food Group B.V.\n\n"
"52608670\n\n"
"Westcon\n\n"
"Group European Operations Netherlands Branch\n\n"
"30221053\n\n"
"Westland Infra Netbeheer B.V.\n\n"
"27176688\n\n"
"Wetransfer B.V.\n\n"
"34380998\n\n"
"WETRAVEL B.V.\n\n"
"70669783")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")