// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)[^\n\d{6,}](?:(?:[a-z\s.]+(\n[a-z\s.])*)|.+)").unwrap();
let string = "xxx
27223525
West Food Group B.V.
52608670
Westcon
Group European Operations Netherlands Branch
30221053
Westland Infra Netbeheer B.V.
27176688
Wetransfer B.V.
34380998
WETRAVEL B.V.
70669783";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}