#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(db\.session\.commit\(\))[\s\S]*?\1"
Local $sString = "db.session.commit()" & @CRLF & _
"#rollback" & @CRLF & _
"user = User.query.get(1)" & @CRLF & _
"print("Some printouts") " & @CRLF & _
"db.session.rollback()" & @CRLF & _
"print("\nCommit the change:")" & @CRLF & _
"db.session.commit()" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Hello: db.session.commit()db.session.commit()"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")