$re = '/(db\.session\.commit\(\))[\s\S]*?\1/m';
$str = 'db.session.commit()
#rollback
user = User.query.get(1)
print("Some printouts")
db.session.rollback()
print("\\nCommit the change:")
db.session.commit()
Hello: db.session.commit()db.session.commit()';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);