using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(db\.session\.commit\(\))[\s\S]*?\1";
string input = @"db.session.commit()
#rollback
user = User.query.get(1)
print(""Some printouts"")
db.session.rollback()
print(""\nCommit the change:"")
db.session.commit()
Hello: db.session.commit()db.session.commit()";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}