re = /(db\.session\.commit\(\))[\s\S]*?\1/m
str = 'db.session.commit()
#rollback
user = User.query.get(1)
print("Some printouts")
db.session.rollback()
print("\\nCommit the change:")
db.session.commit()
Hello: db.session.commit()db.session.commit()'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end