import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<![\\.\\d])(?:[0-9]\\.|1\\d?\\d?\\.|2[0-5]?[0-5]?\\.){3}(?:[0-9]|1\\d?\\d?|2[0-5]?[0-5]?)(?![\\.\\d])";
final String string = "str1 = 'Hello my name is Ben and my IP address is 256.0.0.0'\n"
+ "str2 = 'Hello my name is Folks and my IP address is 1.2.3.4.5'\n"
+ "str3 = 'Hello all, ip addresses: 111.2.3., ip:0.0.0.0, 127.2.1.2'";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}