use strict;
my $str = 'str1 = \'Hello my name is Ben and my IP address is 256.0.0.0\'
str2 = \'Hello my name is Folks and my IP address is 1.2.3.4.5\'
str3 = \'Hello all, ip addresses: 111.2.3., ip:0.0.0.0, 127.2.1.2\'';
my $regex = qr/(?<![\.\d])(?:[0-9]\.|1\d?\d?\.|2[0-5]?[0-5]?\.){3}(?:[0-9]|1\d?\d?|2[0-5]?[0-5]?)(?![\.\d])/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}