const regex = /(?<![\.\d])(?:[0-9]\.|1\d?\d?\.|2[0-5]?[0-5]?\.){3}(?:[0-9]|1\d?\d?|2[0-5]?[0-5]?)(?![\.\d])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<![\\.\\d])(?:[0-9]\\.|1\\d?\\d?\\.|2[0-5]?[0-5]?\\.){3}(?:[0-9]|1\\d?\\d?|2[0-5]?[0-5]?)(?![\\.\\d])', 'gm')
const str = `str1 = 'Hello my name is Ben and my IP address is 256.0.0.0'
str2 = 'Hello my name is Folks and my IP address is 1.2.3.4.5'
str3 = 'Hello all, ip addresses: 111.2.3., ip:0.0.0.0, 127.2.1.2'`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}