const regex = /(?<=[;,])\s+[A-Z]+[:([]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=[;,])\\s+[A-Z]+[:([]', 'gm')
const str = `SAD; Happy; ING:train coca
SAD; Happy; ING(train coca
SAD, Happy, ING[train coca
`;
const subst = ` `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);