use strict;
my $str = 'SAD; Happy; ING:train coca
SAD; Happy; ING(train coca
SAD, Happy, ING[train coca
';
my $regex = qr/(?<=[;,])\s+[A-Z]+[:([]/mp;
my $subst = ' ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";