$re = '/(?<=[;,])\s+[A-Z]+[:([]/m';
$str = 'SAD; Happy; ING:train coca
SAD; Happy; ING(train coca
SAD, Happy, ING[train coca
';
$subst = " ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;